Intermittent cPanel Loading

Incident Report for Neto by Maropost

Postmortem

Summary

On 27 April 2026, some merchants experienced intermittent issues accessing cPanel, with some pages returning a “Software Error” message or taking longer than expected to load.

The issue was short-lived and services stabilised shortly after the initial disruption. We continued monitoring the platform before marking the incident as fully resolved.

Customer Impact

During the incident window, some merchants may have experienced temporary delays or errors when accessing cPanel. The issue did not impact all merchants.

Root Cause

The disruption was caused by a brief spike in database load, which temporarily affected the platform’s ability to serve some cPanel requests normally.

Resolution

Our monitoring detected the elevated load, and the platform’s automated scaling processes responded by provisioning additional capacity. Once the load reduced and scaling completed, cPanel access returned to normal.

No manual intervention was required, and services stabilised within minutes.

Preventive Actions

The platform’s existing monitoring and auto-scaling processes operated as expected and allowed the system to recover automatically. We will continue to monitor platform performance and capacity to help maintain service stability during future load spikes.

Posted May 06, 2026 - 15:43 AEST

Resolved

All services are now running normally.
Posted Apr 27, 2026 - 10:58 AEST

Monitoring

Services are returning to normal. We are continuing to monitor the situation.
Posted Apr 27, 2026 - 10:27 AEST

Investigating

We are receiving reports of some cPanel pages showing "Software Error". Our Development Team are investigating now
Posted Apr 27, 2026 - 10:13 AEST
This incident affected: Control Panel.