Control Panel and Webstore Disruption

Incident Report for Neto by Maropost

Postmortem

Summary

On 4 May 2026, some merchants experienced intermittent access issues with their webstores and Control Panel. During this time, some sites may have displayed a “We will be back online shortly” message.

Impact

The issue caused intermittent availability issues for some merchant webstores and Control Panel access. The impact was not consistent across all sites, and some requests may have succeeded while others failed.

Root Cause

The issue was caused by a sudden spike in automated crawler traffic, which created increased load on the caching layer. This prevented some new connections from being established and resulted in intermittent availability issues.

Resolution

The traffic pattern was identified, and mitigation was applied to reduce the impact of the abnormal traffic while maintaining access for legitimate crawler activity.

Preventative Actions

We have strengthened traffic protection rules to better manage sudden high-volume crawler activity. We are also continuing to monitor traffic patterns and refine platform protections to reduce the risk of similar disruptions.

Posted May 06, 2026 - 12:03 AEST

Resolved

This incident has been resolved.
Posted May 04, 2026 - 13:52 AEST

Update

Some sites may still show "We will be back online shortly" intermittently. Our Development Team is working to resolve the issue as soon as possible.
Posted May 04, 2026 - 10:09 AEST

Monitoring

We are receiving reports that services are returning to normal. We are continuing to monitor the situation.
Posted May 04, 2026 - 10:04 AEST

Investigating

We are receiving reports of sites receiving "We will be back online shortly". Our Development Team are investigating now.
Posted May 04, 2026 - 09:55 AEST
This incident affected: Merchant Store Fronts and Control Panel.