eBay Integration Issue

Incident Report for Neto by Maropost

Postmortem

Summary

On 22 July 2026, merchants using the eBay integration experienced listing updates being skipped with the following error:

“Listing Duration is required. Record Skipped.”

The incident was reported at 9:42 AM AEST and resolved at 4:40 PM AEST, with a total duration of approximately 6 hours and 58 minutes.

We apologise for the disruption caused to merchants using the eBay integration.

Impact

During the incident, affected eBay listing records could not be processed successfully. This may have prevented merchants from creating or updating listings through the integration.

Merchants who saved an eBay listing rule template while the issue was present may also have had some template fields saved without their expected values, despite the correct value continuing to appear in the interface.

Other platform services were not affected.

Root cause

An internal data import process used to update shared eBay information was cancelled before it had completed.

Because the process had already updated part of the dataset, its cancellation left required eBay information incomplete. This caused subsequent listing updates to fail validation and be skipped.

A direct backup and restoration process for the affected shared database was not available. Our Development Team therefore used a point-in-time database recovery process to retrieve and restore the affected information.

Resolution

Our Development Team restored a production database to a separate recovery environment and extracted the affected tables.

The recovered information was then restored across each of the relevant production database clusters. The first restoration was validated by Development and Support before the remaining clusters were updated.

After the restoration was completed, we monitored the integration to confirm that eBay listing records were processing successfully before marking the incident as resolved.

Merchant follow-up

Merchants who saved an eBay listing rule template while the incident was occurring should re-save the affected template.

To identify whether a template was changed during the incident:

  1. Log in to your control panel.
  2. Open Reports.
  3. Select the Staff User Log report.
  4. Enter ebaytmpl in the Page Type field.
  5. Enter edit in the Process field.
  6. Review edits made during the incident window.
  7. Note the affected template IDs shown in the Notes column.
  8. Open and re-save each affected eBay template.

The Listing Duration field may have been saved as blank even though the interface continued to display “GTC.”

Merchants who do not use eBay Business Policies should also review the fields under the template’s Returns section, as these fields may need to be re-entered before the template is saved.

Timeline

All times are in AEST on 22 July 2026.

  • 9:42 AM – Investigation commenced after reports of eBay listing records being skipped.
  • 11:24 AM – Point-in-time database restoration commenced.
  • 11:37 AM – The recovery database was successfully restored.
  • 11:50 AM – The affected information was extracted and prepared for restoration.
  • 12:05 PM – Restoration of the first production database cluster was completed.
  • 12:11 PM – Development and Support confirmed that the first restoration was successful.
  • 12:17 PM – Restoration commenced across the remaining database clusters.
  • 12:43 PM – Restoration was completed across all remaining clusters.
  • 2:33 PM – The fix was confirmed as implemented and monitoring commenced.
  • 4:40 PM – Monitoring confirmed that the integration was operating successfully and the incident was resolved.

Follow-up actions

We are reviewing the following improvements:

  • Adding safeguards around the cancellation of data import processes so that partially completed updates cannot leave shared information in an incomplete state.
  • Improving validation and recovery procedures for shared eBay integration information.
  • Restoring a working shared-database backup process to provide a faster and more targeted recovery option.
  • Reviewing whether additional validation can prevent templates from being saved when required underlying values are missing.
Posted Jul 23, 2026 - 15:30 AEST

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 16:40 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 14:33 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 22, 2026 - 12:12 AEST

Update

We are continuing to investigate this issue.
Posted Jul 22, 2026 - 11:28 AEST

Investigating

We are currently aware of an issue affecting eBay integration, with an error message appearing stating: "Listing Duration is required. Record Skipped.". Our Development Team is actively investigating the issue.
Posted Jul 22, 2026 - 09:42 AEST
This incident affected: Channel Modules.