Purchase Order Email Delivery Failing To Send

Incident Report for Neto by Maropost

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 09:52 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2026 - 09:24 AEST

Update

We are continuing to investigate this issue.
Posted Mar 13, 2026 - 08:56 AEST

Investigating

We are investigating a service interruption to the Purchase Order area of Neto, where emails are failing to deliver. The following error message is being displayed: "Failed to send email. An error occurred. Please check your settings and/or try again later"
Our team is working to identify the cause and will provide updates as we learn more.
Posted Mar 13, 2026 - 08:53 AEST
This incident affected: Control Panel.