Intermittent Control Panel Error

Incident Report for Neto by Maropost

Monitoring

A fix has now been implemented, and we are monitoring the results.

We have introduced additional Cloudflare security protection across Neto merchant sites for certain product search and category filtering requests. This temporary measure is intended to reduce the impact of automated bot traffic contributing to the recent intermittent slowness and “We’ll be back shortly” errors.

Some visitors may briefly see a “Checking your connection” message when accessing these pages. This should complete automatically and will only appear once during that visitor’s session.

Our team is continuing to closely monitor platform performance and the effectiveness of this change.
Posted Aug 14, 2026 - 08:16 AEST

Update

Our investigation has identified increased automated bot traffic contributing to the intermittent slowness and “We’ll be back shortly” errors.

As an immediate temporary measure, we are introducing an additional Cloudflare security check on certain filtered product and category pages. Some visitors may briefly see a “Checking your connection” message, which should complete automatically and will only appear once during that visitor’s session.

We are continuing to work with Cloudflare on longer-term improvements to strengthen bot detection and platform stability.

No action is required from merchants at this time. We will continue to provide updates as the situation progresses.
Posted Aug 13, 2026 - 17:05 AEST

Identified

We continue to see intermittent 503 spikes affecting some merchants, which may result in periods of slowness or brief appearances of the “We’ll be back shortly” page.
Our team has identified the traffic patterns contributing to the issue and continues to make adjustments to the additional protections and mitigations already put in place.
While we are seeing periods of stability between these spikes, the issue is not yet fully resolved. We are continuing to work on improving stability and will provide another update as the situation progresses
Posted Aug 13, 2026 - 14:00 AEST

Update

We are continuing to monitor.
Posted Aug 13, 2026 - 10:51 AEST

Update

Our team continues to monitor the issue and take action to resolve any spikes as quickly as possible.

We are still observing intermittent 503 spikes, which may result in brief appearances of the “We’ll be back shortly” page. While these occurrences are becoming less frequent, we continue to work towards a more stable, permanent fix.

We will continue to monitor the situation closely and take further action as needed.
Posted Aug 13, 2026 - 08:57 AEST

Monitoring

We are currently seeing increased bot traffic that is bypassing some of our existing safeguards.
We have added further protections, which are helping reduce the impact. However, the traffic patterns continue to change, so we are making ongoing adjustments to our mitigations.
We are currently using a more aggressive approach and closely monitoring the situation.
We will provide further updates as the situation progresses.
Posted Aug 12, 2026 - 12:09 AEST

Investigating

We have identified intermittent spikes causing some merchants to receive a “We’ll be back shortly” error when navigating the Control Panel.
We are continuing to investigate and make improvements to prevent these errors from occurring.
Posted Aug 12, 2026 - 08:45 AEST
This incident affects: Merchant Store Fronts, Control Panel, and Point Of Sale Registers.