Phone Line Fault
Incident Report for Maropost Commerce Cloud
Resolved
This incident has been resolved.
Posted May 19, 2023 - 10:40 AEST
Monitoring
Our phone lines are now operating normally.
Posted May 19, 2023 - 10:39 AEST
Investigating
We are currently experiencing faults with our phone lines. Please email support@maropost.com for any urgent enquires.
Posted May 19, 2023 - 09:38 AEST
This incident affected: Support Call Centre.