On 8 July 2026, we experienced an infrastructure issue that affected all Neto merchant webstores and cPanels for approximately 1 hour and 30 minutes.
The incident was caused by a failure within our shared file system infrastructure, which prevented critical services from accessing the files required to serve websites and cPanels. As a result, the platform automatically blocked new requests to protect data consistency, leading to service disruption across all Neto stacks.
Our engineering team responded immediately by restoring the affected file system services, failing over to a healthy infrastructure instance, and replacing impacted virtual machines. Once these recovery actions were completed, all webstores and cPanels were restored to normal operation.
We are continuing our investigation to determine the underlying reason for the file system process failure. Based on our findings, we will implement additional monitoring and alerting, along with any necessary infrastructure improvements, to help detect and prevent similar incidents in the future.
Posted Jul 09, 2026 - 04:36 AEST
Monitoring
The fix to the Network File System is resolved and service is restored. We are continuing to monitor the platform to ensure its availability and stability.
Posted Jul 09, 2026 - 03:38 AEST
Identified
We have identified the issue and have traced to a corruption in the Network File System. We have made the appropriate corrections and the system has begun recovering.
Posted Jul 09, 2026 - 03:21 AEST
Investigating
We are experiencing a service disruption for the Neto Control Panel and Storefronts. We are investigating the solution and will post an update as soon as possible.
Posted Jul 09, 2026 - 03:00 AEST
This incident affected: Merchant Store Fronts and Control Panel.