Webstore Payments Uncaptured/Unresponsive
Incident Report for Maropost Commerce Cloud
Postmortem

Root Cause Analysis:

The downtime was caused by critical system maintenance that was necessary to address underlying issues within our platform. During the maintenance window, unexpected complications arose, prolonging the downtime beyond our initial estimates.

Actions Taken:

Following the downtime, our team immediately conducted a thorough post-mortem analysis to identify the root causes and ensure preventive measures are in place to avoid similar incidents in the future. As a result, we have implemented significant changes to our internal Quality Assurance (QA) processes to enhance the robustness and reliability of our systems.

Improvements Implemented:

  1. Enhanced QA Processes: We have strengthened our internal QA processes to more rigorously test system updates and changes before deployment, ensuring greater stability and reliability.
  2. Improved Communication Protocols: We have revamped both internal and external communication processes to provide more transparent and timely updates during maintenance activities or downtime events. This includes proactive notifications and clearer status updates through various communication channels.

Resolution:

The issue underlying the downtime has been successfully addressed with an update to the affected platform code. Since the implementation of these changes, we have closely monitored the platform's performance, and we are pleased to report that everything related to Stripe payments appears to be functioning as expected.

Continued Commitment:

We want to reassure everyone that we remain committed to delivering a seamless and reliable experience for our customers. Your trust and satisfaction are of utmost importance to us, and we will continue to prioritize the stability and performance of our platform.

Feedback and Support:

If you have any questions, concerns, or feedback regarding the recent downtime or our ongoing efforts to improve our services, please do not hesitate to reach out to our support team. We are here to assist you and ensure your experience with our platform exceeds your expectations.

Posted Feb 24, 2024 - 14:29 AEST

Resolved
Our team have implemented the required fix on impacted merchants and will continue to monitor. If you are still affected and have not yet informed our support team, please reach us at support@maropost.com
Posted Feb 11, 2024 - 10:54 AEST
Monitoring
Our team has deployed a fix for merchants who were affected and reported the problem through our Support Team (support@maropost.com). We have subsequently contacted all the affected merchants with further detail about the fix. We are now in the monitoring phase and will provide more detail in due course.
Posted Feb 10, 2024 - 20:13 AEST
Identified
Our team have identified some potential causes and are investigating a solution. More updates to follow as we work to resolve this.
Posted Feb 10, 2024 - 12:50 AEST
Investigating
We are currently investigating an issue where in some cases checkout/payment pages become unresponsive or where payments are captured but not confirmed leaving them in an uncaptured state. It seems from our initial investigation that it is mainly affecting Stripe. This is an active investigation and we will provide regular updates.
Posted Feb 10, 2024 - 09:12 AEST
This incident affected: Payment Methods.