Control Panel and Webstore Disruption

Incident Report for Neto by Maropost

Postmortem

Neto service disruption: Thursday, 30 October 2025

 

Summary

On Thursday, 30 October 2025, some Neto storefronts experienced errors and became temporarily unavailable. The issue was caused by an error during a routine maintenance change. Service was restored the same afternoon. 

Dates and times (AEST)

  • Start: ~4:23 pm AEST
  • Full restoration: ~5:50 pm AEST

Impact

  • Some storefronts returned errors and checkout was unavailable during the incident window.

What happened

During routine maintenance, an incorrect build was deployed. This introduced a dependency mismatch which caused application errors. Once identified, the change was rolled back. 

 

What we are doing to prevent this in future

  • Tightening release controls to ensure test-only changes cannot be promoted into production
  • Separating configuration and build artefacts by environment
  • Adding extra pre-deployment validation to catch dependency mismatches before release

Next steps

  • We will complete a full internal review of our release and change-management process and implement further guardrails as required.

We know outages interrupt your business and we sincerely apologise for the impact. We will continue to make improvements to prevent a reoccurrence. If you have any issues or questions relating to this incident, please contact Support with “Neto 30 Oct incident” in the subject so we can prioritise your case.

Posted Oct 31, 2025 - 08:25 AEST

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 20:06 AEST

Update

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 17:50 AEST

Monitoring

We are receiving reports of services returning back to normal. We are continuing to monitor the situation.
Posted Oct 30, 2025 - 17:49 AEST

Update

We are continuing to work on a fix for this issue.
Posted Oct 30, 2025 - 17:44 AEST

Identified

We have identified the issue, our team is working to resolve the issue as soon as possible. Please continue to refresh this page or subscribe for updates.
Posted Oct 30, 2025 - 17:17 AEST

Update

We are continuing to investigate this issue.
Posted Oct 30, 2025 - 16:50 AEST

Investigating

We’re aware of an ongoing service interruption. Our engineering team is actively investigating the root cause and working to restore services as quickly as possible. We’re treating this as a top priority and will share updates as soon as they’re available.
Posted Oct 30, 2025 - 16:35 AEST
This incident affected: Merchant Store Fronts and Control Panel.